
Digital Documentation 
(Advanced) using 
LibreOff ice Writer

1

IntroductIon

In Class IX, you have learned the basic concepts of word 

processing using LibreOffice Writer, where the basic 
functions, such as creating, editing and formatting the 

document are covered. However, in today’s professional 

set up, you need to know more features to create a 

document that can be presented in a professional 

style. LibreOffice Writer offers a variety of features 
and commands that enable you to create an attractive 

and presentable document with a consistent format. 

Further, such documents are easy to read, comprehend 

and edit by one and all. 

In this Unit, you will learn to format a document 

using styles, use style formats, create new styles, 

update styles, and apply styles and to use the template 

of another document to format the current document. 

A document with pictures is always easier to 

understand than a text document. Pictures have a 

visual appeal, as our brain responds quickly to colours 

in comparison to any other form of information. In digital 

document, a picture can be a drawing, chart, photo, 
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logo, graph or single video frame. LibreOffice Writer 
provides various tools to work with images. In this 

Unit you will learn to create a document with pictures, 

insert and modify images in the document to make it  

more attractive. 

Later, it discusses some advanced features of 

LibreOffice Writer that are used to create professional 
documents. You will be able to use the feature ‘Table 

of Contents’, which is based on different types of 

heading styles and create professional documents using 

templates. ‘Track changes’, an important feature, used 

to keep a track of editing being done by each user is also 

covered in this Unit.

The screenshots of LibreOffice version 6.4 under 
Ubuntu Linux are used here to demonstrate the various 

processes. The presentation of the screenshots may 

look different in other versions of LibreOffice or under 
Windows platform. But the functionality, features 
and commands are the same in any version under  

any platform. 

notes
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In Class IX, you had learned to create, format and edit 

documents in LibreOffice Writer. In today’s world, a 
document created and presented in professional style 

is appreciated by all. There are two ways of creating 

an attractive digital document in Writer: manually 
formatting a document or by applying styles. 

You learned manual formatting in class IX, where you 

selected a part of a document, such as page, paragraph 

or words and then applied formatting effects using the 

formatting toolbar. To format different portion(s) in the 

document, having same style, steps were repeated for 

all part(s) of the document. So, to change any aspect(s) 

of formatting, the entire process was repeated for the 

document. Manual formatting is popular, as it is easy to 

use and requires less knowledge. Creating a big report 

with consistent format becomes difficult when manual 
formatting is used. To avoid inconsistency in formatting 

and reduce time and effort in formatting a document, we 

use Styles in Writer. In this chapter, you will learn how 
to style a document by using– style formats, creating 

new styles, updating styles, applying styles and using 

template to format the current document. 

Introduction to Styles

A style is a collection of all formatting information, which 

you want to save and then apply on the document. For 

example, following details of Font can be stored as a 

style with the name ‘Title  style’.

Size – 12

Name – Bookman Old Style
Weight –Bold
Alignment – Left

C
H
A
P
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1 Introduction  to  Styles
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Now you can use and consistently apply Title style 

to all titles of the document. To change the style of 

Title in a document, you just need to update the Title 

style and apply it to the document. Similarly, to change 

the format of the complete document, just change the 

style applied to it. Using Style allows you to shift your 

focus from appearance of the document to the content 

of document. This chapter will help you learn how to 

create and apply styles in Libreoffice Writer.

Style Categories

Writer provides six Style categories, which are as follows:

 (a) Page – all documents in Writer are based on 
pages, hence for formatting them, Page Style is 

used. It defines basic page layout like page size, 
its margin, placement of header and footer, 

footnote, borders and background. A document 

can have one or many page styles. If a page style 

is not specified, Writer uses its built-in Default 

page style.

 (b) Paragraph – after deciding on a page format, 

next is the document content, which is organised 

in paragraphs. A paragraph begins and ends 

by pressing Enter key. Paragraph formatting 

includes tab stops, text alignment, line spacing 

and borders. Usually, it also includes Character 

styling attributes.

 (c) Character – this styling is used to work on block 

of letters, i.e. word(s) in the paragraph instead 

of the whole paragraph. By using character 
styles, you can change the appearance of a part 

of a paragraph without affecting the other part. 

Character styles allow changing the text colour, 

text size, highlighting text and emphasising it.  

 (d) Frame – using frames, a document can be 

organised in sections, so that each section 

of the page can have a different appearance. 

Frames are like containers, which can hold text, 

graphics and lists. Therefore, applying Frame 

Styles allows to format a frame by specifying its 

size, position, border and how the text is placed 

around the picture.

notes
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 (e) List – to style lists in a document, the Writer 
provides a separate category. It can be used to 
style lists by putting numbering or bullets of a 
different kind or specify numeric format.

 (f) Table – using tables, a large amount of 
information can be organised and presented 
effectively. Table Style category allows to format 
a table by adding borders, using different text 
or border colour(s), aligning text inside the 
table, having different patterns or text 
colour.

Now we know which Style category should 

be applied to style/format a section of the 

document, let’s learn how to apply it.

Styles and Formatting

Writer provides many options and tools to 
style or format a document. All formatting 

options, learned in Class IX, which can be 

applied using Formatting toolbar, can also be 

applied using Style menu.

There are many predefined Styles in Writer, 
which can be accessed by using the following 

methods:
 (i) Using Style option from Menu Bar

 (ii) Using Style Drop Down list box, as 
shown in Fig. 1.1, from the Toolbar. The 
current paragraph style is displayed 
in the textbox. If the Toolbar is not 
visible then, click on View>Toolbars, 
and enable Formatting/“Formatting 
(Styles)”.  

 (iii) Using Sidebar Menu. On the Sidebar, 
clicking on Styles icon, displays the 
Style sub-menu as shown in Fig. 1.2.

 (iv) Using keyboard shortcut — F11 function 
key.

If you choose to style your document using 

this option, you will find various available 
options on top as shown in Fig. 1.3

In Fig. 1.3, first six icons allow to select 
the category of style, such as Paragraph style, 

Fig. 1.1: Style drop down list in Toolbar

Fig. 1.2: Style sub menu from sidebar

Fig. 1.3: Buttons at the top of sidebar  

sub menu
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Character style, Frame 

style, Page style, List style 

and Table style to work on. 

Click on any one of these 

buttons to display a list 

of existing styles in that 

category. From the bottom 

of the window selecting 

Show Preview option 

displays its style along with 

the name in the list. 

Fig. 1.4 shows the list 
when preview is not selected 

and Fig. 1.5 shows when the 

preview is selected.

At the bottom of this 

menu, there is a Drop Down 

Fig. 1.5: Paragraph Styles with 

Show previews

Fig. 1.4: Paragraph Styles 

without Show previews

list, to select the filter for the style list to be displayed 

above. By default this filter is set to Hierarchical as 

shown at the bottom of Fig. 1.5. 

Assignment 1

Select each of the Styles – Character style, Frame style, Page style, 

List style and Table style and list the styles under each category.

Let us use these styles in a document. For applying any 

styles, such as Paragraph, Character, Frame, Page, List, 

Table follow the given steps.

Step 1. Select the text to be formatted. The selected 
text may be a collection of characters, words, 
lines, paragraph, page, frame or table.

Step 2. To format the selected text, choose appropriate 
style by clicking the button from the top of the 
Styles bar. 

Step 3. A list of styles for that category appears. 
Double click on the desired style to apply to 
the selected text. 

2023-24



Digital Documentation (aDvanceD) using libreoffice Writer 7

Apply an existing Heading style, from Paragraph Styles.

Step 1. Create a new document named ‘noise.odt’ with the text 

as shown in Fig. 1.6. 
Step 2. Add a title, ‘Noise Pollution’ on top.

Step 3. Select the Tile – Noise Pollution

Step 4. Open Styles Menu using Sidebar and go to Headings 

option.

Step 5. Double click on Heading 4 to apply. Observe that the 

Fig. 1.7 shows the Heading 4 style is applied to the 
heading ‘Noise Pollution’.

Fig. 1.6: noise.odt

Fig. 1.7: Applying Heading 4 options of Paragraph Styles

Practical Activity 1.1

Using predefined Heading Style, allow you to use them 
as a Book Mark for browsing the document.

notes
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Apply an existing page style on ‘noise.odt’

Step 1. Open file ‘noise.odt’ created in Activity 1.2.
Step 2. Insert a blank page in the beginning by selecting 

Insert>Page Break from main menu bar, as shown in 

Fig. 1.8.

Step 3.  Observe that in Fig. 1.9, inserting a page break will shift 

the matter to the second page. Now, place the cursor at 

the beginning of page 2, where the matter appears as 

shown in Fig. 1.9.

Step 4. Open Style Menu from side bar and select the Page 

Styles option as shown in Fig. 1.9.

Step 5. Double click on Landscape to change page orientation 

to Landscape. After applying Page Styles, you can 

observe that the document pages orientation is changed 

to Landscape from Portrait. 

Note: Applying page style on a page may affect the entire document. 

Fig. 1.8: Inserting page break

Fig. 1.9: Selecting Landscape from Page Styles option of 

sidebar menu

Practical Activity 1.2
notes
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Fill Format

To apply a style on words present at different locations 

in the document, you will have to go to each word 

separately and apply it on each word. Writer provides a 
convenient way of doing it through Fill Format option. 

It is the second icon from right on the Style menu, as 

shown in Fig 1.3. This method is useful when a same 

style is to be applied at many places scattered in the 

document. Fill Format can be used to style scattered – 

pages, frames, tables, lists, paragraphs or characters. 

Follow the steps given below to use it. 

Step 1. Open the document to be styled.

Step 2. Open the Styles window and select the desired 

style category and then desired style from drop 

down list. 

Step 3. Select Fill Format button.

Step 4. To apply the selected style, take the mouse 
pointer to desired location and click. Do take 

care to apply style on appropriate type of 

content. 

Step 5. Repeat step 4 until all the changes have been 
made for that style in the entire document.

Step 6. To quit Fill Format option, click the Fill 

Format button again or press the Esc key.

Use Fill Format to change appearance of paragraphs at different 

places in the document using paragraph formatting. A file 
‘documentation.odt’ with at least 5 pages of text is used for  

the activity.

Practical Activity 1.3

notesAssignment 2

(i) Try applying Landscape option on one page of a large file.
(ii) Explore, in which situation Conditional Styles filter, given 

in Paragraph category of styling, can be used?
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Step 1. Open a file ‘documentation.odt’ having 5 pages of text. 

Observe the indented sentences in second page in  

Fig. 1.10.

Step 2. Go to Style Menu from sidebar and click on Paragraph 

category, and select List Paragraph from the drop down 

list as shown in Fig. 1.11.

Fig. 1.10: Pages of file documentation

Fig. 1.11: Selecting List paragraph option in Paragraph Styles category

2023-24
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Step 3. Click at the beginning of the sentence to be styled using 

List Paragraph. 

Step 4. Now click on Fill button, keep on doing same to apply 

the style for all sentences using desired format. Observe 

in Fig. 1.12 that how the indented list items look after 

applying the Fill Format button. 

Step 5. Press ‘Esc’ key to disable Fill button.

Fig. 1.12: Using Fill Format button

Creating and Updating a New Style 

Till now you have used only predefined styles to format 
a document. If existing styles specified by Writer do 
not match your requirement, then it is also possible to 

create a Custom Style. There are many ways to create 

a custom style, two of them – From Selection and by 

using drag and drop are explained here.

(a) From Selection – last button in Style menu, is 

Styles action button is used to create a new 

style or modify an existing style. It can also be 

used to load a style defined in document or 
template, in the list. Let us learn how to create 

a new style; which is the first function in the 
drop down list of action button.

2023-24
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Step 1. Select the portion of document, such as page, 
paragraph, character, to change its appearance. 
Format it as per the requirement.

Step 2. From the buttons at the top of the Style menu, 
choose the category (paragraph, character, 
page, etc.) for which a new style is to be created.

Step 3. Select Style action button. A list of options as 
shown in Fig. 1.13 is displayed. Click on New 
Style from Selection.

Fig. 1.13: Selecting New Style 

from Selection to create a New 

Style

Fig. 1.14: Creating a new style MyStyle

Step 4. In Create Style dialog 
window, type the name of 
new style, say, ‘MyStyle’ 
as shown in Fig. 1.14. 
The names of existing 
styles are displayed in the 
window.

Step 5. Click OK to save the name 
of new style. 

 Observe that the name 
of the newly created style 
‘MyStyle’ appears in the 
list of styles.

To create a custom paragraph style ‘myStyle’, using file  
‘noise.odt’ created in Practical Activity 1.2.

Step 1. Open file ‘noise.odt’ created in Practical Activity 1.2.

Step 2.  Format the content of the paragraph with Font face – 

Arial, Font size 12, line spacing 1.5.

Step 3.  Select paragraph button from Style Menu of sidebar as 

shown in Fig. 1.15.

Fig. 1.15: Selecting Paragraph Style

Practical Activity 1.4
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Step 4. Select Style Action button. 

Step 5. Click on New Style From Selection. A Create Style dialog 

box will appear as shown in Fig. 1.16.

Step 6. Type ‘myStyle’ as style name in the box and click OK. 

The Style Name (myStyle) will appear in the drop down 

list under Paragraph category.

Fig. 1.16: Create New style using Selection

Fig. 1.17: New created myStyle becomes part of Style list under 

Paragraph category

Updating a Style

Instead of creating a new style for a small changes in 

predefined style, an existing Style can be modified on 
desired aspect. Updating Current Style (Fig. 1.18), the 

second option in list can be used for doing so.
Fig. 1.18: Selecting Update 

Selected Style option
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Follow the given below steps to modify an existing user 

defined style of page, frame or paragraph style.
Step 1. Select the page/paragraph to be modified.
Step 2. Format the selected portion as per the 

requirement.

Step 3. Go to Style menu, and click on the button to update.

Step 4. Using Style Action button, click on Updated 
Selected Style.

Note – Ensure that the aspect modified remains same 
throughout the selection. For example, in paragraph, if 

you are changing font face or size then, throughout the 

paragraph it should remain same.

Using Drag and Drop

Another way of creating a new style is using Drag and 

Drop method. It is very easy, as the desired formatted 

portion of text is just dragged and dropped at correct 

place in the Style menu.

Use the following steps to create a new Style using 

Drag and Drop method.

Step 1. Select the text from the document and change 
its formatting as desired.

Step 2. From the buttons at the top of the Style menu, 
choose the desired category of style to create.

Step 3. Click on the desired style under which, new 
style is to be created.

Step 4. From the document drag the selected portion of 
text to the Style Menu.

Note – While dragging the text, check the cursor shape, 
as it changes to indicate whether the desired operation 

is possible or not.

Step 5. Create Style dialog window appears (see  
Fig. 1.16), type the name of new style. Names 
of existing styles are displayed in the window.

Step 6. Click OK button to save the name of new style.

The Create Style window displays the list of custom 

styles. To update an existing style, choose the style 

name from the list. So same method can be used to 

create or update a Style. Drag and Drop cannot be used 

to create a Page Style.

notes
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Create a new style ‘myStyle1’ using drag and drop, by changing 

line spacing to 1 and font size to 13 in myStyle.

Step 1. Open file ‘noise.odt’ created in Practical Activity 1.2.

Step 2. Format the content of the paragraph with Font size 13 

and line spacing 1.

Step 3. Select paragraph button from Style menu of sidebar as 

shown in Fig. 1.19.

Step 4. Now drag the selected text to Style menu, as shown in 

Fig. 1.20.

Fig. 1.19: Paragraph Styles in Style menu of sidebar

Fig. 1.20: Creating a new style using drag and drop

Practical Actiivty 1.5
notes
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Step 5.  Press OK. The style name (myStyle1) will appear in the 

drop down list under Paragraph category as shown in 

Fig. 1.21.

Fig. 1.21: New style myStyle1 created using drag and drop appears in 

the style list

Apart from creating a new style or modifying an existing 

style, a new document can be styled/formatted using 

pre-defined templates or another document which suits 
our requirement. This helps in copying all styles of the 

template/document in one go to our Style menu and 

makes formatting our task easy. 

Load Styles (from a template or document)

The last option, in Style Action button of Style Menu 

is Load Styles. It is used to copy styles from an existing 

template or document. Once copied, in the list of styles, 

you can create a new document having same appearance 

as old one with no extra efforts.

Follow the given steps to copy style from template or 

document

Step 1.  In the Styles Menu, click on the Load Styles 
as shown in Fig. 1.22. 

Step 2.  It will open the Load Styles dialog box as 
shown in Fig. 1.23. In the Load Styles dialog 
box, choose the category of your document.

Step 3.  Find and select the desired template to copy 
styles from. Note that there are no templates 
stored in My Templates category.

Fig. 1.22: Selecting Load 

Styles option from Style Action 

button

2023-24
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Step 4. From the same dialog window, 
also, select the options for the 
types of styles to be copied, 
such as Text for Paragraph 
and Character styles, Frame, 
Pages or Numbering (List 
styles). By selecting Overwrite 
option, the styles being copied 
will replace any existing styles 
with the same name.

Step 5. Click OK to copy the styles.

Step 6. In case styles are to be copied 
from a file, then instead of 
Template option, click on the From File button. 
A File Selection dialog box is displayed. Select 
the desired document from your computer.

Applying styles

Whenever a new document is created, 
the Writer applies default style(s) to it, 
and the same is displayed in the status 

bar as shown in Fig. 1.24. 
You may like to retain the default 

style or change it. 

Self Exploration

Learn other ways of accessing Style 

options as listed in section 1.4.  

summary

• A Style is collection of all 
formatting information, which 
you want to save and then apply on the document.

• Writer provides six Style categories – Page, 
Paragraph, Character, Frame, List and Table.

• Predefined Heading style(s) act as bookmarks 
in a document. These bookmarks allow faster 
browsing in a document.

• These Style(s) tools can be accessed from Menu 
bar, Drop Down List and Side bar.

• Fill Format is used to style scattered – Pages, 
Frames, Tables, Lists, Paragraphs or Characters 
in a document.

Fig. 1.24: The current Default Style is displayed on the 

status bar

Fig. 1.23: Selecting the My Templates from Categories 

of Load Styles dialog window
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• Writer allows creating custom style and saving 
them for future use.

• These new styles can be created using Selection 
method or Drag and Drop method.

• Drag and Drop method cannot be used to create 
a Page style.

• A user defined style once created, can be updated 
at any point of time. Steps used for updating a 
style are same as creation of style.

• A document can be styled using another document 
or a template.

1. Mr R K Sharma is planning to change his job. He 

approaches a company (www.naukri.in) for helping him 

in finding new job. Mr Sharma is asked to submit his  
CV/Resume in the company. He has downloaded a 

sample CV from “template.com”. Help him in creating his 

CV in the same format. Also save the format as “CV1” on 

the computer, for future reference.

2. Raghav receives a non-styled text document as shown in 
Fig. 1.25,  from his teacher to convert it into desired 

appearance as shown in Fig. 1.26. He has to save it as 
“reportStyle” for future reference. Write the process that 
he should follow.

Fig. 1.25: Practical Exercise 2 Original Document

notes

Practical Exercises
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3. Kendriya Vidyala No. 3, is planning to publish a monthly 

digital newsletter for their school. Ravish Pandey of class 

12, heads the group responsible to design it on computer. 

Size of news letter finalised is 5 inch (length) by 8 inch 
(height). It was also decided that:
• The newsletter will have two pages with 4 leaves. 
• The first leaf will provide brief information about school.
• The second leaf will have a table, displaying the 

school’s last year’s Board exam results. 
• On the third leaf School achievements (at least 4) for 

the current session will be given.

• The last leaf will have articles or poems (at least 2) 

written by students.

You being part of the team are required to perform the following 

using Style Menu from Sidebar:
(a) Suggest appropriate style category (page, frame, and 

table) to be used to design the newsletter.

(b) Create digital copy of it.

(c) Apply Left Page and Right Page format on appropriate 

leaves.

(d) Also set the same margins on all leaves, having same 

border on all.

(e) Add page number on each leaf. The page number 

should appear in Footer as “Page – number”. Right 

align these numbers on each leaf.

Fig. 1.26: Appearance of Styled Document

notes
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(f) For heading(s) and sub heading(s) use Heading 2 and 

Heading 4, in the newsletter.
(g) On the first leaf, while displaying information about 

school, use character styling of your choice to make it 

attractive.

(h) Use table to style Board Results, using grid rows and 
columns.

(i) Each row of the table should have a number – in 

Roman, prefixed to content.
(j) Organise school achievements in frames, where 

individual frame is to be styled using Frames of 

Paragraph category.

(k) Using selection method, save the style in respective 

category, so that the same can be used to publish 

future newsletters to maintain consistency.

A. Multiple choice questions

1. Which of the following features in LibreOffice Writer is/are 
used to create the given document? 

 (a) Page borders 

 (b) Envelope 

 (c) Picture from 

File 

 (d) Indexes and 

Tables

2. Styles menu (from 

sidebar) in Writer provide options to 
work on 

 (a) Paragraph Styles 

 (b) Frame Styles

 (c) Page Styles 

 (d) All of the above

3. What is style template in LibreOffice Writer? 
(a) Pre-determined form and mode of document file 
(b) One kind of model style 

(c) One type of document 

(d) Cluster of documents in Writer
4. Which of the following gives the status of your document 

like page numbers, number of pages? 

(a) Status bar   (b) Standard toolbar 

(c) Formatting   (d) Title bar

5. Which of the following can be used to access a style menu?
(a) F11 function key (b) Sidebar Menu

(c) Formatting toolbar  (d) All of these

B. Fill in the blanks

1. A __________ is a collection of different formats

2. Styles are especially handy in __________.

Check Your Progress

notes
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3. Proper use of styles improves __________ in a document 

4. The first five buttons at the top of the Styles window select 
the category of __________.

5. Using predefined __________ creates Bookmark in the 
document.

6. On opening a new file _________ Style is used for formatting 
the document.

7. In page layout documents, you can arrange __________ like 
text boxes and graphics.

8. Character styles are often integrated in __________ Style.

9. __________ allows to apply style at different places in  the 
document.

10. Predefined Style __________ be updated by Drag and Drop 
method.

C. Short answer questions

1. What do you understand by styles in LibreOffice writer 
document?

2. Write advantages of using Style over manual formatting, 
for designing a document.

3. What are the different categories of style in LibreOffice 
writer document?

4. Write down the steps to update a style.
5. What do you understand by custom styles in LibreOffice writer?
6. In a document Introduction paragraph is to be designed 

extensively by setting its font (face, size, weight, colour), 

space above it and giving number to heading. Given below 

are the steps used to do so.

 (i) Select the Introduction (paragraph)

 (ii) Open Font list from Toolbar

 (iii) Select the font

 (iv) Open Font size from Toolbar

 (v) Select the desired font size

 (vi) Select Font weight (Bold) from the toolbar
 (vii) Open Font color from Toolbar

 (viii) Select desired color

 (ix) Using Format menu option, select Spacing > Paragraph 

> Indent and Spacing

 (x) Edit space above paragraph

 (xi) Add number by Selecting Numbered list from Toolbar.

7. Give two examples, where instead of Style, using manual 

formatting will be beneficial.
8. Give one situation, in which you will prefer to use Fill 

Format for styling your document.

9. Write steps to load style(s) from a template.

notes
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It is easy to read and comprehend a good interactive 

document. A word processing application has rich 

features, which allows to create an interactive document. 

A document containing pictures is always easier to 

understand than a pure text document. Pictures have 

visual appeal, as our brain responds quickly to colors in 

comparison to any other form of information. A picture 

can be a drawing, chart, photo, logo, graph, or single video 

frame. In digital document a picture can be a graphic or 

image representation, which is a digital image. Till now, 

we have created a text document with different features, 

such as formatting and using styles. In this chapter 

you will learn to create a document with pictures. You 

will learn to insert and modify images in the document 

to make it more attractive. LibreOffice Writer provides 
various tools to work with images. A picture is a digital 

image, which is representation of image in finite set of 
digital values 0 or 1, known as pixels. These are stored 

in various types of graphics files with the file extension, 
such as GIF, JPG, JPEG, PNG, BMP, etc. 

Inserting an Image in a Document

LibreOffice Writer allows to work on images, shapes, 
charts and diagrams by providing various tools. The 

image file stored on the computer, can be inserted into 
a document using different ways, such as using Insert 

Image dialog, using Drag and Drop option, using Cut, 

Copy and Paste option and lastly by Linking. 

Inserting Image Using Insert Image Option 

A general procedure to insert an image using Insert 

Image dialog box, is as follows.

Step 1. Open the document to insert an image in 

LibreOffice Writer.

C
H
A
P
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R

2 Working  with  Images
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Step 2.  Place the cursor where you want to insert an 
image.

Step 3.  Select and click on Insert > Image from menu 
bar

Step 4. An Insert Image dialog box will open which will 
allow to choose the picture file to be inserted.

Step 5.  Select the file and click on Open button to insert 
an image in document.

Practical Acitivity 2.1

Insert an image using Insert Image dialog box in the file 

“noise.odt” created in previous chapter.

Step 1. Ensure that you have an image file on your computer 
hard disk. Otherwise download a relevant image from 

Internet.

Step 2. Open “noise.odt” file created in Practical Activity 1.2 of 
Chapter 1.

Step 3. Place the cursor to the next line of the text to insert the 

image file, and then click on Insert menu from the 

menu bar as shown in Fig. 2.1.

Fig. 2.1: Selecting Insert menu for inserting Image

notes
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Step 4. Click on Image option, opens Insert Image browsing 

window to select an image. Select desired image as 

shown in Fig. 2.2.

Step 5. Click Open button. The image appears at desired place 

as shown in Fig. 2.3.

Fig. 2.2: Insert image browsing window

Fig. 2.3: Image inserted in noise.odt document

notes
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Inserting Image using Drag and Drop option 

Another option to insert images in the document is by 

using Drag and Drop option. The standard procedure 

is just drag the image from its source and drop it at 

desired position in the document. A general procedure 

to insert an image using drag and drop option, is as 

follows.
Step 1. Open the document to insert an image in 

LibreOffice Writer.
Step 2. Open a file browser window (Win+E) and select 

the image file to be inserted.
Step 3. Drag the image into the document 

Step 4. Drop it, where you want it to appear in  
the document. 

Inserting image using Copy and Paste method

As stated above, another way to insert an image in the 

document is by using copy and paste method. In this 

method instead of dragging the image, copy the image 

and then paste into the desired location of the document.

Inserting an image using any of the above described method 

saves a copy of image file in the document wherever image 
is inserted, that means, the image gets embedded in  

the document.

Practical Activity 2.2

Insert an image from one document (source) to another document 

(target) using Clipboard. Source file is “typewriter.odt” having 

different images of typewriter, and target file is “documentation.

odt” created in the previous chapter.

Step 1.  Open source file 
“typewriter.odt” 

and target file 
“documentation.

odt”.

Step 2. In the source 

document, select 

the image to be 

copied, as shown 

in Fig. 2.4.
Fig. 2.4: Selected image in typewriter.odt

notes
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Step 3. Move the mouse pointer over the selected image and 

copy the image by using keyboard shortcut (Ctrl+C) 

or right-click and select Copy option from the context 

menu to copy the image to the clipboard.

Step 4. Switch to the target file, “documentation.odt”.

Step 5. Place the cursor on the location where you want to 

insert the image as shown in Fig. 2.5.

Step 6. Paste the image by using the keyboard shortcut (Ctrl+V) 

or right-click and select Paste option from the context 

menu to paste the image as shown in Fig. 2.6.

          

Fig. 2.5: Placing cursor to insert image in documentation.odt

Fig. 2.6: documentation.odt after inserting image from typewriter.odt

notes
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Inserting an image by linking

If multiple copies of the same image are required to be 

inserted in the document, it is beneficial to save the link 
of image instead of inserting the image. Inserting a link, 

stores its reference instead of the image itself, thereby 

reduces the size of the document, because actual image 

is saved only once as a separate file along with  the 
document. 

Whenever a document containing the link is opened, 
the image file gets merged, at the place(s) where reference 
was stored, and displayed on screen to the user. A 

general procedure to link the image file is as follows.
In Insert Image dialog box, check the Link option as 

shown in Fig. 2.7

Keyboard shortcut to link an image – drag and drop 

the image while holding the Ctrl+Shift keys. 

Fig. 2.7: Link check box in Insert image dialog window

notes

Assignment 1 

Explore how to insert an image from Writer’s Gallery or from 
any other device?

Modifying an Image 

Sometimes we may have to modify the image inserted in 

the document to suit its requirement. The Image toolbar 

is used to resize, crop, delete and rotate the image.

Using the Image toolbar

The image toolbar automatically appears when an image 

is inserted or selected in the document. If you want to 

keep it always on screen, click on View > Toolbars > 

Image from the menu bar. The Image toolbar will be 
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displayed as shown in Fig. 2.8. Table 2.1 describes 

various tools that are made available through this image 

toolbar.

Table 2.1: Description of Image Toolbar

Tool Effect on image

Image Filter 

There are 11 types of filters available 
for improving an image. Details given in 

Table 2.2

Image Mode
Image can be changed to black and white, 

gray-scale or a watermark 

Crop Cuts off non-desirable part of the image

Flip Horizontally Flips the image Horizontally by 180
o

Flip Vertically Flips the image Vertically by 180
o

Rotate 90
o
 left Rotates the image by 90

o
 left

Rotate 90
o
 right Rotates the image by 90

o
 right

Rotate
Image can be rotated by any angle using 

this tool

Transparency
Makes an image transparent by using the 

value provided in percentage

Colour

Using Drop Down list (as shown in  

Fig. 2.9), Red, Blue or Green colour can 
be modified or adjustment for brightness, 
contrast and gamma can be made

To apply any of the tools from image toolbar, select the 

image on which tool is to be applied and then click on 

the tool. Clicking on the colour button will display the 

colour drop down list as shown in Fig. 2.9. It consists of 

six components in the drop down list. One can increase 

or decrease the percentage of these components. The 

first components represent the three primary colours 
Red, Green and Blue, respectively. The fourth component 
represent the Brightness, fifth component represent 
the Contrast and last sixth component represent  

the Gamma.

Fig. 2.8: Image Toolbar

Fig. 2.9: Color dropdown list
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Clicking on Image Filter opens up a window with 

11 filters, as shown in Fig. 2.10. Table 2.2 gives the 
brief description of various tools available in the Image  

Filter window.
Table 2.2: Description of Image Filter

Tool Effect on Image

Invert

Inverts the colour values of coloured 

image. In case image is gray-scale then its 
brightness is inverted.

Smooth
Softens the contrast of image. Another 

dialogue box appears to adjust parameter

Sharpen Increases the contrast of image

Remove Noise Removes single pixels from the image

Solarisation

Used in Photographs to reverse the tone. 

Dark appears light and light appears dark. 

Another dialogue box appears to adjust 

parameter.

Aging

Simulates the effect of time on picture. On 

clicking it, another dialogue box appears to 

adjust parameter.

Posterise

Makes a picture appear like painting by 

reducing colours in the image. Another 

dialogue box appears to adjust parameter, 

when this icon is clicked.

Charcoal Sketch Changes image as charcoal sketch

Relief
Adjusts light source to create shadow using 

dialogue box  to adjust parameter

Mosaic

Joins group of pixels into a single area of 

one colour. Another dialogue box appears 

to adjust parameter.

Fig. 2.10: Image Filter window

Practical Acitivity 2.3

Insert an image in a document 

and rotate the image.

Step 1. Open a new document 

in LibreOffice Writer.
Step 2. Go to Insert menu and 

Select Image >> From 

File

Step 3. Insert an image from 

library as shown in 

Fig. 2.11. Fig. 2.11: Image inserted in a new 

document
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Step 4. Select image and then click on rotate tool. Observe that 
four dots known as handles, appeared on four corners 

of the image.

Step 5. Move the mouse on any corner and observe that the 

‘rotate’ symbol is activated.

Step 6.  Click on rotate symbol on the top right corner of the image 

and drag it to downward direction, as shown in Fig. 2.12.

Step 7. The image rotated is shown in the Fig. 2.13.

Fig. 2.12: Rotating image Fig. 2.13: Image after rotation

notes

Practical Acitivity 2.4

Crop an image in a new file.
Step 1. Open a new document in LibreOffice Writer.
Step 2. Insert an image in the document as shown in Fig. 2.14 

using Insert >> Image >> From File option as 

demonstrated above.

Step 3. Select the image by clicking on the image. Observe that 

the selected image is surrounded by eight small squares 

as shown in Fig. 2.14.
Step 4. Click on crop tool from Image toolbar. Now observe that 

the eight small squares surrounding the image will be 

changed into the blue coloured handles as shown in  

Fig. 2.15. These are the handles used to crop the image. 

Fig. 2.15: Changed handles for 

cropping the image
Fig. 2.14: Document after inserting 

image
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Step 5. Click any of these edges of the image and drag the 

cursor towards the center of image as shown in  

Fig. 2.16. Observe that the image is being cropped up to 
the dotted lines. It is possible to crop the image by clicking 

on dragging any of the edge as per the requirement.

Step 6.  Click anywhere on the page or press Esc key to leave 
the crop tool and observe the cropped image as shown 

in Fig. 2.17.

Fig. 2.17: Image after cropping 

from upper right edge
Fig. 2.16: Cropping the image

Resizing an Image

Sometimes you may want to resize the image to fit an 
image at the desired place in a document. Resizing 

is the process of reducing or enlarging the size of the 

image. This can be done in various ways. Quick and 

easy way to resize an image is by dragging the image’s 

sizing handles. Use the following steps to resize image:
Step 1. Click on the image inserted in the 

previous activity. Observe that there are 
eight sizing handles surrounding the 
image as shown in Fig. 2.14. 

Step 2. Position the pointer over one of the sizing 
handles. The pointer changes shape 
indicating the direction of resizing.

Step 3. Click and drag to resize the image as 
shown in Fig. 2.18.

Step 4. Release the mouse button when satisfied 
with the new size and observe the size of 
the image is reduced.

Fig. 2.18: Resizing the image
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 By dragging the corner handles, one can resize 
both the width and the height of the image 
simultaneously, while the other four handles 
only resize one dimension at a time. 

 Note that while resizing the image its size  
gets changed, but while cropping the image 
cuts it.

Deleting an Image

It is possible to delete the image from the document just 

like we delete the text. To delete the image, just select the 

image by clicking on the image and press the Delete key.

Drawing Objects

If you need to draw a flowchart or a callout box in your 
document, LibreOffice Writer provides the feature of 
drawing tools for such work. The set of drawing tools 

available in Writer are easy to use, and helps in creating 
good quality designs, diagrams and drawings. Once you 

create the drawings, you can directly place it in the 

document. These diagrams can also be copied or 

imported in other packages.

Using Drawing Tools

To display Drawing Toolbar 

in the Writer window, click on 
View > Toolbars > Drawing 

as shown in Fig. 2.19. This 

will display the Drawing 

Toolbar in the Writer window 
as shown in Fig. 2.20. The 

toolbar contains various basic 

drawing objects of different 

types to create any design of 

your choice.

There are many default drawing objects used to 

create designs in document. To use them – 

Step 1. Place the cursor in the document where you 
want the drawing to be placed (anchored). You 
can change the anchor later, if required.

Fig. 2.19: Enabling Drawing tools
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Step 2. Select the tool from the Drawing toolbar as 

shown in Fig. 2.20. The mouse pointer changes 

to a drawing-functions pointer.
Note – One more toolbar appears on the screen, the 

Drawing Object Properties. It is shown in Fig. 2.23 

and explained later. 

Step 3. Move the pointer to the place in the document 

where you want the image to appear and then 

click-and-drag to create the drawing object.
Step 4. Release the mouse button to finish drawing.

The selected drawing function remains active, 

so that you can draw another object of the  

same type. 

Step 5. To cancel the selected drawing function, press 

the Esc key or click the Select icon (the arrow) 

on the Drawing toolbar.

Select

Insert Line

Curve (list)

Polygon

Square

Circle Symbol (list)

Star (list)

Flowchart (list)

Fontwork

Right angle triangle
Rectangle rounded

Rectangle

Curve Oval

Lines & Arrows (list)

Isosceles triangle

Arrow (list)

Call Out (list)

Call outs

Points

Text Box

Toggle Extrusion

Basic shapes (list)

Fig. 2.20: Drawing Toolbar
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Draw a family tree with 3 family members, Mr R K Sharma 

(Grandfather), Mr B Sharma (Father), Mrs Sunita Sharma 
(Mother). 

Step 1. Open a new document in LibreOffice Writer. Enable the 
Drawing toolbar and ensure that it is displayed on the 

bottom of the document window as shown in  

Fig. 2.21.

Step 2. Select Rectangle Round tool from the toolbar. Place 

the cursor on the location where you want to draw the 

family tree, and drag it to create a rectangle. In the 

same manner, create other two rectangles as shown in  

Fig. 2.21.

Step 3. Enter the text in all three rectangular boxes as shown 

in Fig. 2.22. To enter text, select the rectangle and then 

type the text.

Step 4. Select the type of line (simple line and line with arrow) 
from Line tool to draw lines showing hierarchical relation 

as shown in Fig. 2.22.    

Step 5. Save the diagram in file “family.odt”.

Fig. 2.21: Rectangles created using drawing tool for family tree

Practical Activity 2.5
notes

It is also possible to change the properties of the 

object on which you are working. Writer provides tools 
in Drawing Object Properties toolbar for changing 

properties, i.e. customising an object. Using these tools 

the object can be moved, resized, rotated, edited and 

conFig.d on various aspects. 

Properties of the object can be modified or edited, 
either at the time of its creation, i.e. before you start 

drawing them or after its creation. When properties are 
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Setting or Changing Properties of Drawing 

Object

On selecting the drawing  

object, in the document, 

Drawing Object Properties 

Toolbar is displayed as shown 

in Fig. 2.23. It is a floating 
toolbar, and can be placed 

anywhere on the screen. 

To set the properties before drawing the object, follow 

the given steps.
Step 1. From the Drawing Toolbar, select the object 

you want to draw.

Step 2. From Drawing Object Properties Toolbar, 
click on the icon of property to be modified.

Step 3. Change the value of parameter.

Step 4. Repeat steps 2 and 3 to change all desired 
properties.

Fig. 2.23: Drawing Object Properties Toolbar

modified before creation, it is known as setting default 

value(s). To work on properties, you can use tools from 

the toolbar and change the desired aspect of the object. 

Properties can also be modified by right clicking on  
the object.

Fig. 2.22: Drawing of family tree using rectangles
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Step 5. Draw the desired figure by following the steps 
given in the previous section.

Changes done in properties of an object, before creating it, are 

available only for current session. 

Follow the steps for changing properties of the object 

after drawing it.

Step 1. Select the object whose properties are to be 
modified.

Step 2. Follow steps 2 to 5 of the previous process of 
setting Properties before drawing an object.

In the file “family.odt” created in Activity 2.5, add two more 

members, a son Master Rohit Sharma and a daughter Baby 
Deepika Sharma. Make a copy of the file. Then change the 
properties of Rectangle as (Fill color – lime yellow, border line 

– Orange having 0.08” width) and Line (color – black, Style – 

ultrafine dashed) used in Family Tree. 
Step 1. Open file “family.odt” in LibreOffice Writer.
Step 2. Add two rounded rectangle and add text in them to 

reflect two more members in the diagram.
Step 3. Save a copy as “family1.odt”. Keep on working in  

“family.odt”

Step 4. Select a rectangle using selection tool. 
Step 5. Click on Fill Color tool in Drawing Object Properties 

toolbar, and change the color selected rectangle as 

shown in Fig. 2.24.

Fig. 2.24: Using Fill Color tool for rectangle

Practical Activity 2.6

notes
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Step 6. In the same way change color of all the rectangles.
Step 7. Select a line in the drawing. Click on Line Color tool 

and select Black color to change the line color from blue 
to black. In the same way, change the color of all the 

lines to black as shown in Fig. 2.25. 

Step 8.  You can also change the border color of rectangle using 

Line color tool and width of the border by specifying the 

value in line width option.

Step 9. Alternately you can change the line color and width by 

right clicking on the object and then selecting the “Line” 

option from the context menu as shown in Fig. 2.26.

Fig. 2.25: Using Line Color tool for changing the line color

Fig. 2.26: Right clicking on object to select Line option from 

context menu

notes
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Step 10. To change the line color and width of all the rectangles, 

select all the rectangles by holding shift key and clicking 

on each rectangle. This will open the Line dialog window 

as shown in Fig. 2.27. Change the line color to “Orange” 

and specify the line width as “0.08” as shown in  

Fig. 2.27 and click on the OK button.

 Observe in Fig. 2.28, the line color and width changed 

as specified 

Fig. 2.27: Specifying line color and line width for selected objects in the 

Line dialog window

Fig. 2.28: Family Tree with desired object properties

notes
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Resizing and Grouping objects

Sometimes you may want to change the size of drawing 

to accommodate it at a particular place in the document. 

This can be done either by changing its size only or by 

changing its shape and size both. Follow the given steps 

to resize a drawing.
Step 1. Select the object to be resized. All eight handles 

on the corners and edges will be visible.

Step 2. Click on any of the handles and drag it to its 
new place. The object will be scaled up or down, 
depending on your action. Also whether object’s 
shape will be retained or not, will depend on 
the handle you choose for resizing.

Step 3. For resizing and maintaining original shape of 
drawing, use corner handles.

Step 4. Using edge handles will resize drawing  
non-proportionally. 

Assignment 2 

Use SHIFT key, while resizing the object, in both the cases 

and observe the difference in action.

While drawing an object comprising more than one 
overlapping shape, on screen they stay together looking  

like a single entity. But actually they are different shapes 
placed together as different entities. So, when you 

choose to edit them you have to work on each individual 

shape. To treat these shapes as one Fig., they may be 

grouped together.

Grouping drawing objects

LibreOffice Writer allows grouping these different shapes, 
to behave as a single entity without affecting their size 

and position. Once grouped, all shapes belonging to 

that group become its member and a change applied on 

one member works on all. Follow the given below steps 

to group the drawing objects.

To group drawing objects: 
Step 1. Select the object by clicking over it. 

Step 2. Hold the Shift key and keep on selecting all 
other objects by clicking on it to be included in 
the group.

notes
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Step 3. Select a group tool from Drawing Object 
Properties Toolbar (Fig. 2.23). Alternatively, 
selecting from main menu Format > Group > 
Group will also do same work.

Step 4. This process will group the selected drawing 
objects. 

There are four options under Group option. These are 

Group, Ungroup, Enter Group, Exit Group. The icons as 

shown in Fig. 2.29 for these options also present in the 

Drawing Object Properties Toolbar.

Fig. 2.29: Grouping tools in 

Drawing Object Properties 

toolbar

Practical Activity 2.7

Group all items of Family tree created in Activity 2.5 and 2.6, in 
the file “family1.odt”. Using the group, change the properties of 
Rectangle (Fill color – lime yellow, border line – orange with 0.08” 

width) and Line (color – black, Style – ultrafine dashed) used in 
Family Tree.

Step 1.  Open the document “family.odt” created earlier in Writer.
Step 2.  Select all the lines. For this click on the first line, hold 

the Shift key and keep on selecting other lines to group 

them.

Step 3.  Click on Group tool in Drawing Object Properties 

toolbar. Observe that all the lines are grouped together 

as shown in Fig. 2.30. Now change the color of all lines 

grouped together to black.

Fig. 2.30: All the lines are grouped together and changed 

the color to black
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Positioning Image in the Text

Once the task of creating, formatting, resizing and 

grouping the drawing object is complete, it has to be 

positioned in the document with text and other image 

or drawings. Positioning of an image is controlled by 

four settings.
 (i) Arrangement

 (ii) Anchoring

 (iii) Alignment

 (iv) Text Wrapping
These settings can be accessed using three ways – 

by using Format menu, by using context menu after 

right clicking on the object, by using Drawing Object 

Properties Toolbar for changing the properties of the 

drawings. Let us learn how to use Drawing Object 

Properties Toolbar to position a drawing in the page.

Arrangement

In Overlapping objects arrangement determines the 

position of the current drawing with respect to other 

drawings or text. The Drawing Object Properties 

toolbar consists of the arrangement tools as shown 

in Fig. 2.31. These are the six tools in the order of 

appearance from left to right, namely Bring to Front, 

Forward One, Back One, Send to Back, To Foreground, 

To Background, which are briefly explained in Table 2.3.
Table 2.3: Description of Image arrangement tools

Tool Effect

Bring to Front Place image on top of all objects / images

Forward One
Bring image one level up, when there are 
overlapping images

Back One Sends image one level down in overlapping 

images

Send to Back Place image at the bottom of all objects/ 

images

Fig. 2.31: Image arrangement 

tools in Drawing Object 

Properties

Step 4.  Similarly select all the rectangles, group them and 
change its fill color to lime yellow, border line to orange 
color and border width to 0.08, as done in previous 

activity. Observe that the color of all the rectangles 

changed to orange colour as shown in Fig. 2.28.
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To Foreground Moves the drawing object in front of the text

To Background Moves the drawing object behind the text

Note – First four settings can be applied on an image 

or drawing, but last two are available for drawings only.

Anchoring

It acts as a reference point for image or drawing. 

Anchoring allows an image to retain its position to a 

page, paragraph, character or frame. Anchor tool is 

shown in Fig. 2.32. Clicking on the downward arrow 

you can observe that an image can be anchored to Page, 

Paragraph, Character or Frame. So whenever a page, 

paragraph, character or frame is aligned, the anchored 

image moves along with it.

Alignment

It allows the vertical or horizontal placement of the 

image with respect to its anchor. Alignment tools are 

located under Drawing Properties Toolbar, as shown 

in Fig. 2.33. An image can be aligned in six different 

styles – 3 horizontal and 3 vertical.

Text Wrapping

It allows the placement of image in relation to text. Text 

Wrapping tools are available under Drawing Object 

Properties Toolbar. There are six choices, namely Wrap 
off, Page Wrap, Optimal Page Wrap, Wrap left, Wrap 
right, Wrap through, in the order of their appearance 
from left to right as shown in Fig. 2.34. Table 2.4 briefly 
describes these tools.

Table 2.4: Description of Text Wrapping tools

Tool Wrapping Effect

Wrap off Text is placed above and below the image

Page Wrap Text flows around the image. Moving an 
image will rearrange the text on the page

Optimal Page 

wrap

In Page Wrap, if the space between image 
and margin is less than 2 cm then text will 

not be placed on that side

Wrap left Text is placed on left side of the image

Wrap right Text is placed on the right side of the image

Wrap through Superimposes the image on the text

Fig. 2.32: Anchored tool with 

its options

Fig. 2.33: Alignment tools 

in Drawing Object Property 

toolbar

Fig. 2.34: Text wrapping tools 

in Drawing Object Properties 

toolbar
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summary

• In a digital document, a graphic or image is called 
digital image.

• A digital image is represented in pixels.

• Predefined image can be inserted using Drag-
Drop method, Copy-Paste method or using Insert 
Image dialog box.

• Inserting an image embeds a copy of the image in 
the document.

• An image can be linked to a document using 
Insert Image dialog box.

• Linking an image saves only the link of the image 
instead of embedding the image. This saves 
space in case multiple copies of the same image  
are required.

• Image Toolbar can be used to modify an image. 
Tools for filtering, resizing, cropping, deleting and 
rotating an image are available in this toolbar.

• Drawing Tools are used to create pictures (objects), 
such as Flowchart, Call out box, designs, etc. 

• Properties of Object can be customised by resizing, 
rotating, moving or editing.

• Drawing object properties can be modified either 
at the time of creation (when you start drawing) 
or after its creation.

• Properties when modified before creation, is 
known as setting Default values.

• An object drawn using different shapes, can be 
grouped to behave as single object.

• Writer provide various tools to arrange text and 
image or drawing on a page.

Practical Exercises

Q.1  In Practical Exercise of chapter 1 (Question 3), you created a 

school newsletter. Leaf-wise content of the newsletter were: 
 (a) School Information

 (b) Result for Class X & XII in table

 (c) School Achievement

 (d) Students’ article(s)/poem(s)

notes
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For improving the visual appeal of the newsletter, add some 

images in it. Following are the details given for adding images.

Leaf 1: Add a relevant photo 
of school in bottom 
right corner, as 
shown in picture. 
Photo should have 
good contrast and 
brightness. Add black 
border to photo.

Leaf 2: Add photograph 
of toppers of Class 
X and Class XII. 
Make adjustment to 
display photograph 
of student in 
appropriate table 
and in front of their 
name. As this page 
might be printed in 
black, convert them 
to grayscale with 
proper contrast.

Leaf 3: Add few relevant 
pictures in the given 
style on this leaf. Apply at least two types of image filter 
on the pictures.

Q.2  Master Udit is helping his drawing teacher to create digital 
drawings. His teacher asks him to write down the steps 
to create the following two drawings. In the first drawing, 
objects are grouped and second drawing was created by 
resizing objects of first drawing. How would you help her 
to do so using drawing tools of Writer?

Q.3  Miss Roshni has 

downloaded a flowchart 
to be included in her 

report. She asks for 

your help, in creating 

an editable copy of 

the flowchart. Write 
steps to draw it using 

Drawing tools of Writer.

notes

Start

End

Read Input

Process Data Create Report

End of  
Data

Read Input

2023-24



Digital Documentation (aDvanceD) using libreoffice Writer 45

A. Multiple choice questions

 1. The text or image which appears faintly in the background 

of a page is called _________________.

(a) Water mark   (b) Trade mark 
(c) Copyright   (d) Embossing

 2. JPG or JPEG in image format stands for _________________.

(a) Joint Photographic Experts Group

(b) Joint Picture Experts Group 

(c) Joint Photographic Experts Graph 

(d) Joint Photographic Experts General 

 3. In Drawing Object Properties toolbar, Grouping options 

provided are _________________.

(a) Exit Group   (b) Ungroup 

(c) Enter Group  (d) All of these

 4. Which of the following is not the correct file extension for 
an image file? 
(a) GIF    (b) JPEG 

(c) Odt    (d) PNG

 5. Image toolbar does not provide a tool for _________________.

(a) filtering   (b) cropping 
(c) copying   (d) flipping

B. Fill in the blanks

 1. _________ tool cuts off non-desirable part of the image.
 2. To change both brightness and contrast of the image 

________________  tool can be used.

 3. To simulate the effect of time on picture _____________ 

tool is used.

 4. _________  place image at the bottom of all objects.
 5. An image can be deleted by ____________  it and pressing 

DELETE key.

 6. In drawing tools, basic shapes list provide ____________  
shapes.

 7. Anchor act as _____________  point for a drawing.

 8. There are ________________ options for aligning an image 

horizontally.

 9. The ___________ handles of image are used for rotating it.

 10. Changing properties of an object _____________ creation,  

retain them throughout the session

C. Short answer type questions 

1. What is a digital image? How can you create one?
2. Write steps to insert an image from the gallery using 

Drag and Drop method.

Check Your Progress notes
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3. How is resizing of image different from cropping it? 

4. What are the tools available in drawing toolbar? Describe 
any five tools.

5. How is linking of an image different from embedding? 

Give a situation in which you would prefer to link  

an image.

6. Write steps to change properties for drawing objects.
7. What are the benefits and drawbacks of grouping drawing 

objects?

8. Describe any two tools from Drawing Object Properties 

toolbar.

9. Write steps to insert an image in a basic drawing shape.
10. Write factors controlling positioning of an image in  

a document.

notes
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As we all know that LibreOffice Writer is a word processor 
that provides a variety of features. You have already 

learned some of the features, such as formatting, editing, 

inserting tables and images, styling the text and inserting 

graphics in the document. In this chapter, you will be 

learning some advanced features of LibreOffice Writer 
that will be used to create professional documents. To 

give the listing of the contents of the document, we can 

use the Table of Contents feature, which is based on 

different types of heading styles. LibreOffice Writer also 
provides templates to create professional documents. 

When multiple users are working on a single document, 
the Track Changes feature can be used to keep a track 

of the editing being done by each user.

Table of Contents

In Class IX, you had learned to insert tables in a 

document, where the data was represented in a row and 

column format. In this chapter, we will discuss Table of 

Contents (ToC). You must have seen table of contents 

in the beginning of your books. It contains a list of topics 

and subtopics that have been covered in the book along 

with page numbers.

Table of Contents, allows to insert an automated 

table of contents in a document. The entries or contents 

of this table are automatically taken from the headings 

and sub headings of the document. Also, these contents 

are hyperlinked in the table. So by clicking on any topic 

in the table of contents, we can navigate directly to the 

selected topic. But before creating table of contents, 
you need to first understand the concept of hierarchy 
of headings.

C
H
A
P
T
E
R

3 Advanced  Features  of  Writer
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Hierarchy of Headings

LibreOffice Writer supports up to 10 levels of headings H1 
to H10. These headings are applied to the headings of the 

document. The following process will demonstrate how 

to apply these headings to the headings in the document. 
Step 1. Create a new document in 

LibreOffice Writer and enter 
the text Heading 1 to Heading 
10 as shown in Fig. 3.1.

Step 2. Click on the Styles button 
from the right side bar. Click 
on the Paragraph Styles and 
then Headings. The Styles 
dialog window will display the 
list of headings from Heading 
1 to Heading 10 as shown in 
Fig. 3.1.

Step 3. Place the cursor on Heading 
1 as typed in the document. 
Then click on the Heading 1 
from the Styles dialog window. 

Step 4. Repeat Step 2 for the words 
Heading 2 to Heading 10. 

Step 4. Observe that Heading 1 to 
Heading 10 is applied to the 
words Heading 1 to Heading 
10 of the document and these 
headings have changed as per 
the applied style as shown in 
Fig. 3.2. Observe the change 
in Figs. 3.1 and 3.2.

Once the desired heading styles 

are applied in the document, the same 

hierarchy will be reflected in the table of 
contents also. 

Creating a Table of Contents (ToC)

Before you start creating the table of contents or ToC in 
a document, you must ensure that proper heading 

styles, such as Heading 1, Heading 2, Heading 3 and so 

on are inserted in the document. The correct ToC will be 

Fig. 3.2: Document after applying 10 Headings

Fig. 3.1: Hierarchy of 10 Headings
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generated only if proper paragraph styling for headings 

is applied to the document. Once a styled document is 

created, follow the steps given below to insert the ToC in 

the given document:
Step 1. Open the earlier 

created file 
“documentation.odt”.

Step 2. Assign proper heading 
styles to the various 
headings in the 
document from the 
Styles dialog box. For 
example, assign the 
heading styles as 
shown in Fig. 3.3 in 
the “documentation.
odt” file.

Step 3. Place the cursor at 
the position where the 
table of contents is to 
be inserted. Usually, it 
is in the beginning of 
the document.

Step 4. From main menu, 
select Insert > Table of 
Contents and Index 
> Table of Contents, 
Index or Bibliography. 
The Table of 
Contents, Index and 
Bibliography dialog 
box will be displayed as shown in Fig. 3.4.

Step 5. By default, the Type tab will be selected with 

a preview of ToC on the right side of the dialog 

box. On the left of the dialog box, is the Types 

and Title section. In the Title text box, the 

default name of the ToC, i.e. Table of Contents 

is displayed. You can change this name, just 

by typing in the text box. Type the desired title 

of the ToC say “Contents” in the Title text box. 

The title will be changed in the Preview section 

as shown in Fig. 3.4. 

Fig. 3.3: Planning for assigning headings styles

Fig. 3.4: Table of Contents, Index or Bibliography dialog box
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By default, the checkbox 
for Protected against 

Manual Changes option is 

selected. This protects the 

ToC from any accidental 

change. If this box is 

unchecked, then the 

contents of ToC can be 

changed directly on the 

document page, just like any 

other text on the document.

In the Create Index or 

Table of Contents List 

box, the Entire Document 

option is selected in the For 

list box. So the ToC will be automatically created from 

the headings and sub-headings of entire document.
The Outline check box is selected, so the complete 

outline of the ToC is shown in the preview. Click and 

deselect it if you do not want to see it. 
Step 5. Click OK button. The Table of Contents will be 

inserted in the document as shown in Fig. 3.5.

Note that all the headings will appear with page 

numbers in the ToC. The entries in the ToC are 

hyperlinked. Moving a mouse pointer over any of the 

entries will show a tool tip stating to press Ctrl+click to 

open hyperlink  followed by the heading title. Pressing 

Ctrl+click the cursor will directly move on to the selected  

section heading.

Fig. 3.5: Table of Contents inserted in a document

Practical Activity 3.1

Rimjhim has created a report on Environmental Pollution 

in LibreOffice Writer. She has applied proper heading styles 
to all section headings of the document. Now, to add table of 

contents to the document with the heading as Rimjhim’s Table 

of Contents, follow the steps given below. 

Step 1. Open the document in LibreOffice Writer.
Step 2. Select Insert > Table of Contents and Index > Table 

of Contents, Index or Bibliography. The Table of 

Contents, Index and Bibliography dialog box will be 
displayed.
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Step 3. In the Type the Titles text box, type Rimjhim’s Table of 

Contents. 

Step 4. Click OK. The Table of Contents will be inserted in 

Rimjhim’s document.

Customisation of ToC

Once the ToC is inserted, we can 

customise it according to our 

requirements. To do so, right click 

anywhere on the ToC and select 

Edit Index option from the popup 

menu as shown in Fig. 3.6. 
The Table of Contents, Index 

or Bibliography dialog box will 

be displayed as shown in  

Fig. 3.7. As seen in the previous 

section, the dialog box has five 
tabs – Type, Entries, Styles, 

Columns and Background. The 

options in these tabs can be used 

to edit the table in various ways. 

The changes made will be 

reflected in the Preview section 

of the dialog box. 

Fig. 3.7: Selecting Entries Tab in Table of Contents, Index or Bibliography dialog window

Fig. 3.6: Selecting Edit Index option from the pop up menu
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 Type Tab: is active by default after opening 

the Table of Contents, Entries or 

Bibliography dialog box to insert 

the ToC.

 Entries Tab: contains options to set styles for 

various entries in the ToC.

 Styles Tab: contains options to apply the desired 

styles to the text of each level in the 

table of contents. To apply a custom 

paragraph style to any level, follow 

the steps given below.

Step 1. Click and select the level from the Levels list 
box.

Step 2. Click and select the desired paragraph style 
from the Paragraph Styles list box.

Step 3. Click the OK button to apply the selected 
paragraph style to the selected outline level. 
The assigned style appears in square brackets 

Fig. 3.8: Background Tab in Table of Contents, Index or Bibliography 

dialog window

in the Levels 
list and will 
also be visible 
in the Preview 
pane.

Step 4. Click OK 
button to apply 
the selected 
styles. 

To remove the applied 

paragraph styling, 

select the desired level 

in the Levels list box, 

and then click the 

Default button.

 Columns Tab: contains options to set the number 

of columns that we want to have in 

our ToC.

Background Tab:  contains options to change the 

background of the ToC as shown in 

Fig. 3.8. The current background 

color will be displayed in the Active 

Color window. 
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To change the background color follow the following 

steps.
Step 1. Click the Color button on the top of the  

dialog box.

Step 2. Select the desired color from the Colors palette. 
The selected color 
will appear in the 
New color window. 

Step 3. To add the selected 
color to the custom 
palette, click Add 
Button below the 
color palette. Now, 
the added color 
can be re-used 
whenever required.

Step 4. Click OK to apply 
the desired color to 
the ToC (Fig. 3.9).

To remove the 

background colour from 

the ToC, click None button 

present on the top of the 

dialog box. 

LibreOffice Writer also 
allows to add a graphic as 

a background of the ToC. 

For this, select the Bitmap 

button in the Background 
tab of the dialog box. 

Select the desired graphic 

option and click OK button  

(Fig. 3.10). 

Maintaining a Table of Contents

As we know now that a table of contents is a snapshot 

of the entire document at any given point in time. If any 

changes are made to the document section headings 

or page numbering, it should be reflected in the Table 
of Contents as well. Maintaining a Table of Contents 

consists of updating and deleting the ToC.

Fig. 3.9: ToC with changed background color

Fig. 3.10: Adding graphic as a background of the ToC
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Updating the ToC

Writer does not update the ToC automatically.  
The following activity shows how to update a  

ToC manually.

Practical Activity 3.2

Some more sections are added in the document, accordingly the 

ToC needs to be changed. To update a ToC manually, follow the 

steps given below. 

Step 1. Right-click anywhere in the ToC.
Step 2. From the pop-up menu as shown in Fig. 3.11, select 

Update Index option. Writer updates the ToC so as to 
reflect any changes made in the document. The reflected 
changes in ToC is shown in Fig. 3.12.

Fig. 3.12: Updated ToC

Fig. 3.11: Selecting options for updating and editing a ToC

notes

2023-24



Digital Documentation (aDvanceD) using libreoffice Writer 55

Rimjhim has edited her document after the ToC was inserted. 

Now she wants to update the ToC and also wants a pink coloured 

background. Write the steps that Rimjhim should follow.
Step 1. To update the ToC, right-click anywhere in the ToC. 

From the pop-up menu, select Update Index option as 

shown in Fig. 3.11.

Step 2. To apply a coloured background, right click anywhere 

on the ToC and select Edit Index option from the pop- 
up menu. 

Step 3. From the Table of Contents, Index or Bibliography 

dialog box, select the Background tab. The current 

background color will be displayed in the Active Color 

window.

Step 4. Click the Color button on the top of the dialog box.

Step 5. Select the desired color from the Colors palette. The 

selected color will appear in the New color window. 

Step 6. Click OK to apply the desired color to the ToC.

Deleting ToC

To delete the ToC, right click on the table and select 

Delete Index option from the pop-up menu. The ToC will 
be deleted.

Practical Activity 3.3

Using Templates 

A template is a preset layout that helps to create 

professional and/or formal documents easily. In the 

previous chapters, we have learned styling of different 

document objects using templates. In this section, we will 

learn to create document templates. Sometimes there is 

a need to copy specific content including graphics, such 
as logo of a company, image of a product or text, such 

as tag lines of a product or a company, legal notices or 

even headers and footers in multiple documents. 

Instead of adding and then formatting the objects 

in all documents, we can use templates. For example, 

templates can be used to create a resume, chapter or 

project report. A template can contain all the features 

or objects that a regular document can contain – text, 

graphics, styles and can even use any language. In a 

template we can create and save defined headings, text 
formats, styles, page numbers, headers and footers. 

notes

2023-24



Domestic Data entry operator – class X56

When new documents are created from these templates, 
they have the same content segregation, formatting 

features and appearance as that of the applied templates. 

At the same time, Writer also allows us to edit the 
styles and contents of the document to which the 

template is applied. All documents in Writer are based 
upon templates. If no specific template is specified, then 
Writer uses the default template as blank document 
template for the file being created. 

Checking the template of the document

To see what template is associated with a document, 

select Properties option from the File menu. The 

Properties dialog box will be displayed as shown in  

Fig. 3.13. Since the document was created from the 

default template, no template is listed in Fig. 3.13. 

Fig. 3.13: Document properties with no template
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When the document is created with template, this 
window will display the name of the template. For 

example, if you want to create a document with template. 

Follow the steps given below.
Step 1. Create a new document from File > New > 

Templates …

Step 2. A template selection window will be displayed 
as shown in Fig. 3.14. Select a template, for 
example, select the first template ‘Modern 
business letter’.  

Step 3.  Click on Open button, a document with 
the selected template will open as shown in  
Fig. 3.15.

Step 4.  Now check the template of the created 
document from File > Properties. Observe 
that the template name ‘Modern business letter 
sans-serif’ is displayed under Template in the 
Property dialog box as shown in Fig. 3.16. 

Fig. 3.14: Selecting a template
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Fig. 3.16: Document Properties with template name Modern business letter sans-serif

Fig. 3.15: Document created by selecting template
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Creating a Template

You have learnt how to create a 

document with predefined template. 
It is also possible to create your own 

template and save the current styles 

and appearance of a document for 

future use. Follow the steps given 

below to create and save a template  

in Writer.
Step 1. Open the document in 

LibreOffice Writer whose 
template is to be created.

Step 2. From main menu bar, select 
File > Templates > Save. 
The Save As Template 
dialog box appears as 
shown in Fig. 3.17.

Step 3. Type the name of the new 
template (T1) in Template 
Name text box.

Step 4. Select the category of the 
template being created. 
A category is just like a 
folder that helps to organise the templates. 
Some of the categories that can be seen in 
the dialog box are My Templates, Business 
Correspondence, Online Business Documents  
and Presentations.

Step 5. Click and select Set as default template 
checkbox to make the current template as the 
default template. 

Step 6. Click Save button to save the template.  
A template in Writer is saved with an extension 
.ott. Now this template file can be used by any 
document in LibreOffice Writer.

Using In-built/Saved Templates
LibreOffice allows to use the in-built templates, online 
templates as well as the templates created and saved 

by us. Follow the following steps to use a predefined 
template to style a document.
Step 1. Open the new document in LibreOffice Writer.

Fig. 3.17: Save As Template dialog box
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Step 2. From main menu bar, select File > Templates 
> Manage Templates. You can also use the 
keyboard shortcut key Ctrl+Shift+N to open 
the Templates dialog box. The Templates dialog 
box will be displayed as shown in Fig. 3.18 
showing a list of all available templates. Observe 
that it also shows the Template T1 created in 
the previous section.

Step 3. Select the desired template, (say T1) and click 
Open button. The new document (with name as 
Untitled) will be opened with the same content, 
appearance and formatting effects as the saved 
template.

Step 4. Make the desired changes and save the file.

Fig. 3.18: Templates dialog box
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Practical Activity 3.4

Niaz works in a garment factory. He has to give the report of each 

garment being designed and stitched in his factory. His manager 

wants the same type of report for each garment. Instead of typing 

every time, he has been suggested to use the template feature 

of Writer. He wants to create his own default template and then 
use it to create multiple reports with same format and style. Give 

the solution to complete this task.

Procedure

Follow the following steps to create and save a template in Writer.
Step 1. Create or open the document whose template is to be 

created.

Step 2. From main menu bar, select File > Templates > Save. 

The Save As Template dialog box appears as shown in 

Fig. 3.17.

Step 3. Type the name of the new template (Niaz_template) in 

the Template Name text box.

Step 4. Select the category of the template (Business 

Correspondence) 

Step 5. Click and select Set as default template check box.

Step 6. Click Save button to save the template with an extension 

.ott. 

Now follow the steps given below to use the template.

Step 1. Select File > Templates > Manage Templates.

Step 2. Select the desired template, (Niaz_template) from the 

Templates dialog box.

Step 3. Click on Open button. The new document with  

name as Untitled, will be opened with the same 

content, appearance and formatting effects as the 

saved template.

Step 4. Make the desired changes and save the file.

Using Online Templates 

LibreOffice provides a wide range of online templates, 
which can be downloaded from Internet. Once these 

templates are installed on the computer, they will 

appear in Templates window. To view and select 

online templates provided by Writer, follow the steps  
given below.
Step 1. From main menu bar of LibreOffice Writer, 

select File > Templates > Manage Templates.

notes
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Step 2. Templates dialog box will be displayed as shown 
in Fig. 3.18. Observe the small circular icon 
Browse Online Templates in the lower left corner 
above the Help button.

Step 3. Click on Browse Online Templates button on the 
bottom left of the Templates window (Fig 3.19). 
The official templates page of OpenOffice Writer 
(https://extensions.libreoffice.org/templates) 
will open in the browser as shown in Fig. 3.20.

Fig. 3.19: Browse Online Templates option in Templates dialog box

Fig. 3.20: The official templates page of libreoffice.org
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Step 1. If you click on any of the templates, you will see 
the detailed information about that template. 

Step 2. Download the desired template, say Calendar 
Creator and save it on your computer.

Step 3. Open LibreOffice Writer.
Step 4. Click File > Templates > Open Template...

Step 5. From the Open dialog box, browse for the 
template Company Letter, that is to be opened, 
and click on Open button.

Step 6. The template file Company Letter.ott will open.

Step 7. Make the desired changes in the content  
or appearance. 

Step 8. Save the file as text file Company Letter.odt

Libreoffice.org also provides extensions on https://
extensions.libreoffice.org/extensions. These are 
independent programs that can be added or removed 

from the main existing application. Some templates 

are available in the form of extensions which can be 

downloaded and installed on the computer. 

Importing a Template

Once a template is downloaded and saved in any file or 
folder, it is possible to import it so that it is visible in the 

list of templates in the Templates dialog box. Use the 

following steps to import the template.

Step 1. Open the Templates dialog box.

Step 2. Click Import Templates button located in 
the bottom right corner of the dialog box. The 
Select Category dialog box will open as shown 
in Fig. 3.21.

Step 3. To add the new template into any existing 
category, click and choose that category from 
the list box. Otherwise click and select Create 
a New Category check box. 

Step 4. Type the name of new category in the text box.
Step 5. Click OK button. The Open dialog box will 

appear.

Step 6. Browse for the folder where the downloaded 
template file Company Letter was saved. 

notes
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Step 7. Select the file and click Open button. The 
selected file will be added to the list of templates 
as shown in Fig. 3.22.

Fig. 3.22: Templates dialog box showing the imported template

Fig. 3.21: Select category dialog box
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Niaz’s colleague, Balwinder has to create Employee IDs for all the 
employees of her company, but there is no pre-defined template 
for the same. She searched some templates on the Internet 

that suit her requirement. Although, she has learned to create 

and use a template but does not know how to download and 

use an online template from the Internet. How will she resolve  

this issue?

Follow the steps given below to solve this problem.

Step 1. Open the new document in LibreOffice Writer.
Step 2. Open the Templates dialog box by using the keyboard 

shortcut Ctrl+Shift+N.

Step 3. Click on the Online Templates button.

Step 4. From the templates page in the browser click and 
select the desired template, Employee ID Badge, as 

shown in Fig. 3.23. The description of the template will  

be displayed.

Practical Activity 3.5

Fig. 3.23: Online template Employee ID Badge

notes
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Step 5. Download the template Employee ID Badge and close the 

browser. By default the template gets downloaded and 
saved in Download 

folder.

Step 6. Open Templates 

dialog box again 

and click on Import 

button, as shown 

in Fig. 3.24. 
Step 7. Then select the category in the Select Category dialog 

box and click on OK button as shown in Fig. 3.25.

Step 8. Browse the Download folder to select the template 
Employee ID Badge, as shown in Fig. 3.26.

Fig. 3.25: Selecting Category while importing Template.jpg

Fig. 3.26: Select the template Employee ID Badge to import

Fig. 3.24: Clicking on Import Template

notes
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Step 9. Click on Open button to add the Employee ID Badge 
template. The template imported appears in the list of 

templates as shown in Fig. 3.27.

Step 10. Double click on Employee ID Badge template. A new 

file in a new window with the selected template will be 
opened as shown in Fig. 3.28. 

Step 11. Make the desired changes and save it as a  

document file.

Fig. 3.27: Updated list of templates in Template dialog window

Fig. 3.28: New document created with selected template

notes
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Editing a Template

Once a template is created, desired changes can be 

made in it by following the steps given below.
Step 1. Click File > Templates > Manage Templates. 

The Templates dialog box will be displayed.

Step 2. Right click on the template file (say T1) that has 
to be edited. 

Step 3. Select the Edit option from the popup menu. 
The template file will be opened. Make the 
desired changes and save the file. Now if we 
apply this template for any document, the 
edited file will be used.

Setting Up a Custom Default Template

Any template can be set as a default template. Writer 
gives a blank document as a default template. At the 

same time, any template file can be set as a default 
template by following the steps given below.
Step 1. Open the Templates dialog box by pressing 

Ctrl+Shift+N.

Step 2. Right click on the template that you wish to set 
as the default template. 

Step 3. From the popup menu, select option Set as 
Default as shown in Fig. 3.29. 

The default icon will 

appear on the top left 

of the template file. The 
next time you create 

a new document by 

selecting File > New > 

Text Document, the 

new document will use 

the last edited template. 

Moving a Template

When you place a 
mouse pointer on any 

of the templates in 

the Templates dialog 

box, a tool tip appears 

displaying the name of Fig. 3.29: Setting up a default template

2023-24



Digital Documentation (aDvanceD) using libreoffice Writer 69

the template and its respective category. You can move 

a template from one category to another by following the 

steps given below.
Step 1. Open the Templates dialog box. 

Step 2. Click and select the template to be moved. 

Step 3. Click Move button. 

Step 4. Select the new category where the template has 
to be moved.

Step 5. Click OK button.

Exporting a Template

Export template feature 

allows to store the 

template file in the 
desired folder on your 

computer. It is different 

from moving a template 

from one category 

folder to another. When 
a template is exported, 

it is saved as a template 

file at any desired 
location. Exporting the 

template is a useful 

feature for sharing the templates with multiple users. 

Follow the steps given below to export a template:
Step 1. In the Templates dialog box, select the template 

to be exported. 

Step 2. Click on 
Export button 
located in the 
bottom right of 
the dialog box 
as shown in 
Fig. 3.30. 

Step 3. Then the 
Select Path 
dialog box 
appears as 
shown in Fig. 
3.31 to select the folder where you want to 
export the template.

Fig. 3.30: Selecting Export Template button

Fig. 3.31: Select Path dialog box
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Step 5. Select the folder and 
press on OK button. 
The selected template 
will be exported in 
that folder and a 
confirmation dialog 
box, as shown in  
Fig. 3.32 will be 
displayed.

Applying Templates to a 

Blank Document
You can apply the template 

from the available template list 

to any blank document. Follow 

the steps given below to apply 

the template.

Fig. 3.32: Confirmation after exporting a template

Step 1. Open a new document in LibreOffice Writer by 
selecting File > New > Text Document.

Step 2. Select File > New > Templates to display the 
Templates dialog box.

Step 3. Select the desired template. The template will be 
opened in a new window. 

Step 4. Copy the entire content of the template by using 
keyboard shortcut key Ctrl+A for selection and 
Ctrl+C to copy.

Step 6. Open the blank document and paste the copied 
content of the template by using keyboard 
shortcut key Ctrl+V.

Step 7. Add or delete the content as desired and save it 
as a text file.

Once a template is created, it can be applied to an 

existing document by selecting Insert >Text From 

File option. Browse and select the template file 
that has been saved on the computer. The selected 

template will be inserted in the document.
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Niaz wants to store the template created by him and another one 

that was imported by Balwinder in a folder named Company_
Templates on the desktop. 

Follow the steps given below to complete this task.

Step 1. Create a new document in LibreOffice Writer and press 
Ctrl+Shift+N to open the Templates dialog box.

Step 2. Select the template (Niaz_template)  to be exported. 

Step 3. Click Export button in the bottom right of the dialog 

box. The Save As dialog box appears.

Step 4. Browse for the folder named Company_Templates stored 

on the desktop.

Step 5. Click Select Folder button to export the selected 

template. 

Step 6. Repeat the steps 1 to 5 to import the template Employee 
ID Badge in the Company_Templates folder. 

Practical Activity 3.6

Track Changes Feature 

Track Changes is a powerful tool that makes the 

process of commenting, editing and reviewing of a 

document easy between multiple users. A document 

created by one user need to be reviewed and edited 

by self or other users. If any modifications are made 
in the document directly, the original document might 

get lost. Instead, the Track Changes feature of Writer 
offers an alternative method to keep a record of all the 

changes made in the original document. All the changes 

that are recorded can be either accepted or rejected by 

the original author. Furthermore, the Track Changes 

feature also gives us the option to add comments while 

reviewing a document. 

The Track Changes toolbar contains various tools 

that help to track the changes made by different users. 

To view the Track Changes toolbar, from main menu 

bar, select View > Toolbars > Track Changes. The 

Track Changes toolbar will appear in the bottom left 

corner of the Writer window as shown in Fig. 3.33.

Fig. 3.33: Track Changes Toolbar
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The various buttons present on the Track 

Changes toolbar shown in the Fig. 3.33 are briefly  
explained below.
 (a) View Track Changes – Clicking on this button 

displays all the changes made in the document 
by different users.

 (b) Record Track Changes – Clicking on this 
button, turns on the Track Changes feature. 
After this, any sort of editing done will be marked. 
Any character added to the document will be 
displayed in a different color and any deletion 
done will be seen in strike-through style.

 (c) Previous Track Changes/Next Track Changes 
– Click on these buttons to navigate between 
the changes made. 

 (d) Accept/Accept All Track Changes – Once the 
editing is done, the original author may accept 
the change made to the document by clicking 
Accept All Track Changes button will accept 
all the changes made to the document.

 (e) Reject/Reject All Track Changes – The original 
author of the document may reject a single 
change or all changes made to the document by 
clicking Reject Track Changes or Reject All 
Track Changes button, respectively.

 (f) Manage Track Changes – By clicking on 
this button the Manage Changes dialog box 
is displayed, which contains a detailed list 
of all changes made to the document along 
with the author’s name and date and time of 
modification. 

 (g) Insert Comment – This button is used to add a 
comment in a document. 

Preparing a Document for Review

Track Changes feature is used when a document is 

shared with one or more users for review or editing 

purposes. So, before the document is shared, one should 

make sure that the changes made should be recorded. 

This will ensure that after the review is done, the original 

author of the document has the option to accept or 

reject the changes made. Hence, before the document is 

notes
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sent for review, the original author should prepare the 

document for review and start recording the changes 

being made. For that, select Edit > Track Changes 

>Record option. Alternatively, select the Record button 

from the Track Changes toolbar. To make sure that no 

user is able to disable the track changes option, we can 

protect the document with password. Follow the 

following steps for the same.
Step 1. Create a new document in LibreOffice Writer. 

From the main menu, select Edit > Track 
Changes > Protect option. The 
Enter Password dialog box will 
appear as shown in Fig. 3.34. 
Alternately, you can click on Protect 
Track Changes button located on the 
Track Changes Toolbar to protect 
the document.

Step 2. Enter the same password in 
Password and confirm text box and 
click on OK button. After protecting 
the document with password, if 
any user tries to disable the Track 
Changes feature, Writer will prompt 
to enter the password.

Recording Changes

Once the Track 
Changes features is 
ON, the reviewers 
can begin recording 
the changes in the 
document. For that, 
click Edit > Track 
Changes > Record 
option. Alternatively 
select Record button 
from the toolbar. The 
shortcut key to start 
recording the changes 
is Ctrl+Shift+C.

Once the Record 
option is selected, 

the Track Changes 

Fig. 3.34: Enter Password dialog box allowing 

to enter password after clicking on Protect 

Track Changes button

Fig. 3.35: Recording the changes
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feature is ON. Now, any 

character being deleted will be 

shown as strike through text 

and any character added will 

be shown in different colour as 

shown in Fig. 3.35. Also when 

you place the mouse pointer 

over any of the changes, a tool 

tip is displayed giving details of 

the author, change made, date 

and time of change done as 

shown in Fig. 3.36.
To stop recording, deselect the record option by 

selecting Edit > Track Changes > Record or click the 

Record button on the toolbar. 

Accepting and Rejecting Changes

Once the changes are made by all the reviewers, the 

original author may accept or reject them. Open the 

document and follow the steps given below.
Step 1. To accept or reject a change, click on the change 

made and then select Accept Track Change / 
Reject Track Change button. 

Fig. 3.37: Manage Changes dialog box

Fig. 3.36: Tool tip showing the details of changes made

Step 2. To navigate between the 
changes made to the 
document click Previous 
Track Changes and Next 
Track Changes buttons. 

Step 3. To accept or reject all the 
changes made, select 
Accept All Tracked 
Changes / Reject All 
Tracked Changes button 
respectively.

Step 4. If Manage Track Changes 
button is clicked, a Manage 
Changes dialog box appears 
as shown in Fig. 3.37. It 
contains the details of all 
the changes made in the 
document. The dialog box 
contains buttons to accept 
and reject changes as well.

2023-24



Digital Documentation (aDvanceD) using libreoffice Writer 75

Adding Comments 

To add comments while reviewing, we can use the 

Track Changes toolbar as well. Click at the place in 

the document where the comment is to be placed. 

Thereafter, follow the steps given below to add comments 

in a document.
Step 1. Click Insert Comment button on the Track 

Changes toolbar. A comment box will be inserted 
on the right side of the window. It will have the 
name of the author or reviewer and date and 
time of the comment being made, as shown in 
Fig. 3.38.

Step 2. Type the comment.

Step 3. Once done click anywhere on the document to 
activate it. 

If more than one or two of users add comments then 

the comments by different users will be shown in 

different coloured comment boxes in Fig. 3.38.

Fig. 3.38: Inserting Comments using the option under Track Changes toolbar
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Deleting Comments

To delete any comment, click on the down arrow on the 

bottom right of the comment box. A popup menu will be 

displayed as shown in Fig. 3.39. It gives the option to 

delete only the current comment, all comments by a 

particular author and to delete all comments. Select the 

desired option. 

Comparing Documents

Once the reviewers have made the changes and given 

their comments, Writer allows to compare the original 
document with the reviewed document and then choose 

the option(s) that suits the best. Follow the steps given 

below to compare the documents.
Step 1. Open the edited document. 

Step 2. Select Edit > Track Changes > Compare 
Documents option. Alternatively, click 
Compare Non-Tracked Changed Document 
from the toolbar. 

Fig. 3.39: Deleting Comments from pop-up menu
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Step 3. The Compare To dialog box will appear. Browse 
and select the original file to be compared as 
shown in Fig. 3.40.

Step 4. The Manage Changes dialog box is displayed as 
shown in Fig. 3.37. Accept or reject the desired 
changes.

Step 5. Close the dialog box when done.

Step 6. Save the edited file. 

Fig. 3.40: Selecting original file

Practical Activity 3.7

Pradeep has created a document on ‘Humans and Nature’. 

He wants his friends to review the document and give their  

comments wherever required. The following process will 

demonstrate how his friends add comments in the document.

Step 1. Open the document created by Pradeep to review.

Step 2. Click on Insert Comment button on the toolbar.

Step 3. Type the comment in the comment box.

Step 4. Once done click anywhere on the document to activate 
it. 

Step 5. Repeat the steps given above to add more comments in 

the document.
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After incorporating the reviews, Pradeep mailed the document to 

his editor with the Track Changes ON. He made certain changes 

in the document. Pradeep wants to compare his original 

document with the reviewed document. The following process 

will demonstrate how Pradeep will compare the edited document 

with the original document. 

Step 1. Open the edited document. 

Step 2. Select Edit > Track Changes > Compare Documents 

option.

Step 3. The Compare To dialog box will appear. Browse and select 
the original file to be compared as shown in Fig. 3.40.

Step 4. The Manage Changes dialog box is displayed as shown 

in Fig. 3.37. 

Step 5. Accept or reject the desired changes.

Step 6. Close the dialog box when done.
Step 7. Save the edited file.

Practical Activity 3.8

summary

• A Table of Contents (ToC) contains a list of topics 
and subtopics that have been covered in the book 
along with page numbers.

• A ToC in Writer allows to insert an automated 
table of contents in a document. 

• The contents in the ToC are hyperlinked in the 
table.

• LibreOffice Writer supports up to 10 levels of 
headings H1 to H10. 

• To insert a ToC, select Insert > Table of Contents 
and Index > Table of Contents, Index or 
Bibliography. 

• To add a graphic as a background of the ToC, 
select the Bitmap button in the Background tab 
of the Table of Contents, Index or Bibliography 
dialog box.

• Once inserted, a ToC can be edited or deleted 
from the document.

• A template is a preset layout that helps to create 
professional and/or formal documents easily. 

• In a template we can create and save defined 
headings, text formats, styles, page numbers, 
headers and footers. 

notes
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• The new documents created from these templates 
have the same content segregation, formatting 
features and appearance as that of the applied 
templates. 

• To create a new document with a template, select 
File > New > Templates …

• To create and save your own template, select File 
> Templates > Save. 

• LibreOffice provides a wide range of online 
templates which can be downloaded from then 
Internet. 

• Once these templates are installed on your 
computer, they will appear in Templates window 
from where they can be viewed and selected.

• Any template can be set as a default template.

• Export template option allows to store the template 
file in the desired folder on your computer. 

• Exporting a template is a very useful feature to 
share the templates with multiple users. 

• Track Changes feature of Writer makes the 
process of commenting, editing and reviewing of 
a document easy between multiple users. 

• The Track Changes feature of Writer helps to  
record all the changes made in the original 
document. All the changes that are recorded can be 
either accepted or rejected by the original author. 

• The Track Changes feature also gives us the option 
to add comments while reviewing a document. 

• The Track Changes toolbar contains various tools 
that help to track the changes made by different 
users. 

• To view the Track Changes toolbar, from main menu 
bar, select View > Toolbars > Track Changes.

 1. Rajnikant has created a detailed report on Education in 

India using the LibreOffice Writer tool. He has styled the 
document well by inserting proper paragraph and section 

headings. His colleague Murugan advised him to insert 

a Table of Contents that will give a complete glimpse of 

his report. Help Rajnikant to insert a ToC with a green 

background. 

Practical Exercises

notes
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 2. After the ToC was inserted, Rajnikant made some changes 

in the report but the changes were not reflected in the 
ToC. Will he have to again insert a new ToC? Suggest him 
a better way to update the ToC.

 3. Rukhsat has just downloaded a template from  

libreoffice.org. Now she wants to import it in My templates 
category of the Templates folder. How can she complete 

her task?

 4. Rimit loves to create cards on his computer. This time he 
decided to make his own Christmas cards and send them 

to his friends. He wants to do the task using the templates 

feature of Writer. He has already saved and imported the 
desired template(card.ott). Help him to create cards for at 

least five of his friends.
 5. Teena is a member of the editorial team of her school. 

She wants to set the newspaper template as her default 

template. Write the steps to help Teena complete  
the task.

 6. Venkat has created a document on India’s Trade Review. 
He wants two of his friends, Rinky and Sujoy to review 

his document and if required, add comments to it. But 
none of them know how to use the Track Changes feature 

of Writer. Help them to complete the task.
 7. Venkat has received the reviewed file with modifications 

and comments. What steps will he follow now to accept 
or reject the changes done by his friends.

 8. Write steps to compare the original document created 
by Venkat and the edited document sent by Rinky and 

Sujoy.

Check Your Progress

A. Multiple choice questions

1. Which of the following is NOT true about Table of Contents, 
Index or Bibliography dialog box?
(a)  It has four tabs 

(b) On the Type tab, by default, the checkbox for Protected 

against Manual Changes option will be selected. 

(c) The Styles tab contains options to change the 

background colour. 

(d) None of the above

2. Which of the following tabs is by default active when the 
Table of Contents, Entries or Bibliography dialog box is 
opened? 

(a) Entries   (b) Background 
(c) Styles   (d) Type
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3. Which of the following tabs contains options to set styles 
for various entries in the ToC? 

(a) Entries   (b) Background 
(c) Styles   (d) Type

4. Which of the following can be added in the background of 
Table of Contents in LibreOffice Writer? 
(a) Color   (b) Graphic 

(c) Both a and b  (d) Neither a nor b

5. Which of the following is NOT true about templates? 
(a) The styles and formatting features can be reused. 

(b) LibreOffice provides online templates 
(c) We cannot create our own templates. 
(d) None of the above.

6. Which of the following is the shortcut key to open the 
Templates dialog box? 

(a) Ctrl+Alt+N   (b) Shift+Ctrl+N 

(c) Ctrl+Alt+T   (d) Shift+Alt+T

7. Which of the following buttons, in the Templates dialog 
box, will be clicked to save a template displayed in the list 

of templates? 

(a) Export   (b) Import 

(c) Move   (d) None of the above

8. Which of the following is the shortcut key to select he 
entire document? 

(a) Ctrl+S   (b) Ctrl+A 

(c) Ctrl+D   (d) Ctrl+B

9. Which of the following is the correct sequence of options to 
open the Templates dialog box? 

(a) File > Manage Templates > Templates 

(b) File > Templates > Manage Templates 

(c) Insert > Templates >Manage Templates 

(d) Insert > Manage Templates > Templates

10. Which of the following is true about Track Changes feature 
of Writer? 
(a) You cannot record a change made in the document. 

(b) A comment of a particular author only can be deleted 

(c) Any change made to the document is permanent. 

(d) None of the above

11. Which of the following menus contains the Track Changes 
option? 

(a) File    (b) Edit 

(c) View    (d) Insert

12. Which of the following is the shortcut key to start recording 
the changes being made in the document? 

(a) Ctrl+Shift+C.  (b) Alt+Shift+C 

(c) Ctrl+Alt+C   (d) Shift+C+F2
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B. Fill in the blanks

 1. To navigate to the topic from the ToC, press ___________ 

key while clicking the mouse button on that topic.

 2. To remove the applied paragraph styling in the ToC, select 

the outline level in the Levels list box, and then click the 

_______ button.

 3. If the checkbox for___________________ option is selected, 

the ToC is protected from any accidental change. 

 4. To update the ToC manually, right click and select 
___________ option from the pop up menu.

 5. The ___________ tab contains options to set the number of 

columns that we want to have in our ToC.  

 6. A ________________________ is a preset layout that helps us 
to create professional and formal documents easily.

 7. The default template in Writer is ____________________.
 8. To find the template that is being used in the current 

document, select ___________ option from the File menu.

 9. The ____________________ button is clicked in Templates 

dialog box to view online templates.

 10. The __________________ feature of Writer offers us an 
alternative method to keep a record of all the changes 

made in the original document.

 11. The shortcut key to start recording the changes is 

_________. 

 12. After the Track Changes feature is ON, the added 

characters are shown as ____________ text.

C. State whether the given statements are True or False

 1. The topics in Table of Contents are hyperlinked.

 2. The Table of Contents in LibreOffice Writer can be updated 
automatically.

 3. TABLE of Contents can be inserted even if the section 
headings are not styled.

 4. Once a ToC is created, it cannot be edited.
 5. We cannot add a graphic as a background of ToC.
 6. A single template can be used for multiple documents.
 7. A template cannot contain graphics.

 8. All documents in Writer are based upon templates.
 9. The online templates cannot be added to the list of 

templates in the templates dialog box.

 10. A template once created can be edited again and again.

 11. The changes recorded have to be accepted by the original 
author.

 12. We can delete the comments added in a document by the 
user.
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D. Answer the following questions

1. What is the need of table of contents?
2. What will happen if the ‘Protected Against Manual 

Changes’ option is not selected in the Type tab of Table of 

Contents, Index or Bibliography dialog box?
3. Name the five tabs present in the Table of Contents, Index 

or Bibliography dialog box.
4. What do you mean by customization of ToC?
5. How headings and sub-headings of a document 

differentiated in ToC?

6. Define a template.
7. Give any one advantage of using a template for your 

document.

8. What is the difference between importing and exporting a 
template?

9. Name any two categories of templates.

10. When is exporting of templates useful? Give any one 
reason. 

11. What is the difference between Accept Track Change and 
Accept All Tracked Changes buttons?

12. How do we prepare a document for review?

13. Identify and label the Record button, Insert Comments 

button, Accept All Tracked Changes, Reject Track Change 

buttons in the following figures of Track Changes toolbar 
(shown in Fig 3.41).

14. Identify and label “Browse Online Templates button,  

Export button, Import button” in the following Templates 

dialog box.

Fig. 3.41: Track Changes Toolbar
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